Last week we performed a large overhaul of the composer setup for the CMS. In previous versions we depended heavily on master braches introducing unfortunate effects when accidentally updating the vendors. We fixed this by cleaning out all composer files and using as much stable versions as possible. You can now install a stable version of the CMS by running:

php composer.phar create-project kunstmaan/bundles-standard-edition path/to/install

At the same time we made all bundles compatible with Symfony 2.3 and higher by depending on ~2.3. This will allow you to use Symfony 2.3 if you want a LTS release, or 2.4, 2.5, ... if you want the latest and greatest. We have not yet tagged a stable release of this 2.4 version of the CMS, but you can start using it by running:

php composer.phar create-project kunstmaan/bundles-standard-edition path/to/install -s dev

This is about as stable as the CMS was before the stability upgrade of last week, so don't hesitate to use it. 

If you find anything that does not work as expected, just submit an issue or open a pull request on Github!